Forum

HomeHomeCoreCoreGeneralGeneralOpenWebStudio 02.03.02 (ALPHA) is available! OpenWebStudio 02.03.02 (ALPHA) is available!
Previous
 
Next
New Post
1/10/2019 11:56 AM
 
I also have a module that loads [PortalSettings.ActiveTab.SkinSrc,System] into a session variable. With Enable Ajax Interaction Off it works fine. When Enable Ajax Interaction On it fails and the session variable is loaded with nothing. So is there a problem with system variables?
New Post
1/11/2019 6:05 AM
 

It shouldnt be a problem with the build, although I havent exclusively tested for it. I suspect it has something to do with the format of the string itself. Can you provide an example so I can take a look? You can just email it to me directly - kevin.schreiner at openwebstudio.com


Kevin M Schreiner
Open Web Studio
PayPal - The safer, easier way to pay online!
New Post
1/11/2019 6:07 AM
 

In regards to the system variable specifically - yes- that may be a problem and I'll test specifically for it. The system variables tie directly to the core DNN framework, rather than something inside of the OWS runtime. So if DNN changed that specific variable (which is likely), it would no longer function. I'll see what happened.


Kevin M Schreiner
Open Web Studio
PayPal - The safer, easier way to pay online!
New Post
2/27/2019 5:38 AM
 
I believe I have discovered a rather major bug with OWS 2.3.2, which I am running on a test DNN 9.2.2 server. Any attempt to use action Email to send an outgoing email results in this:


Send Email From: test <no-reply@test.com>. To: [Email,Form]. With a subject of "Information you requested about your account".
Parsing [From]: test <no-reply@test.com>
Parsing [To]: test@test.com
The Action failed to terminate gracefully: System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary. at System.ThrowHelper.ThrowKeyNotFoundException() at System.Collections.Generic.Dictionary`2.get_Item(TKey key) at r2i.OWS.Wrapper.DNN.DataAccess.Factories.EngineFactory.GetHostSettings(String parameter) at r2i.OWS.Wrapper.DNN.Entities.EngineController.GetHostSettings(String parameter) at r2i.OWS.Actions.EmailAction.Handle_Action(RuntimeBase& Caller, DataSet& sharedds, MessageActionItem& act, ActionExecutionResult& previous, Debugger& Debugger) at r2i.OWS.Actions.Runtime.ExecuteAction(DataSet& sharedds, MessageActionItem act, ActionExecutionResult& PreviousAction, Debugger& Debugger)


On our production server, which is using OWS 2.2.21 on DNN 9.1.1, the exact same OWS module sends the email successfully:


Send Email From: test <no-reply@test.com>. To: [Email,Form]. With a subject of "Information you requested about your account".
Parsing [From]: test <no-reply@test.com>
Parsing [To]: test@test.com
Send Mail: Sending 'Information you requested about your account', To 'test@test.com', cc '', bcc ''.
Server:
From: "test" <no-reply@test.com>
To: test@test.com
Cc:
Bcc:
Subject: Information you requested about your account
Send Mail: Send Completed.


Note that we do not have any of the SMTP server settings set at the bottom of the Email action. SMTP server settings are derived from web.config. This has always been the case for us. The failure to send outgoing emails has only been detected on the DNN 9.2.2/OWS 2.3.2 test server, which otherwise mirrors our production server and runs identical code and identical OWS modules. I've noticed also that CC and BCC error out as well.
New Post
4/5/2019 7:11 PM
 

Hi

Is there a quick fix for the missing paginate at the OWS administration page

Alaa

Previous
 
Next
HomeHomeCoreCoreGeneralGeneralOpenWebStudio 02.03.02 (ALPHA) is available! OpenWebStudio 02.03.02 (ALPHA) is available!


 

New York, NY • Baltimore, MD • Vienna, VA • St. Louis, MO • Seattle, WA • info@openwebstudio.com

Bookmark & Share Bookmark and Share