HomeHomeCoreCoreGeneralGeneralOpenWebStudio 02.03.02 (ALPHA) is available! OpenWebStudio 02.03.02 (ALPHA) is available!
New Post
7/15/2018 11:08 AM

This is an alpha build and not every aspect has been fully tested. The UserLogin Issue identified in the previous thread (2.3.0) has been resolved. The hanging "Fetching Data..." reported in previous thread (2.3.1) has been resolved. Additionally, the Input Action has been adjusted to force TLS1.2 connections when using HTTPS.

The new release maps functionality for DNN9 support, and fixes a few issues along the way. Primarily - the AppSetting for the connection string is no longer necessary. The build requires Full Trust at present, so please make sure that the web.config is configured properly. Additionally - DNN9 no longer contains the SharpZipLib, which OpenWebStudio uses. This has been included in the package by default.

Please install this in a development environment until you are certain there are no issues. Please update this forum if there ARE any issues!

Finally - OWS was migrated to github back in 2013. The latest code branch is present there, and will continue to be supported in that location. The SourceForge location will contain only release packages from now on.

Now - go grab a copy! (SourceForge)



Kevin M Schreiner
Open Web Studio
PayPal - The safer, easier way to pay online!
New Post
7/18/2018 4:33 PM

I'm uploading a file, then testing if it's an image using [FORMAT,PATH,{FILE.IMAGE}] so that I can create a thumbnail image of it, but I'm getting nothing returned from the test eg:

If '[format,frmFile,form,{FILE.IMAGE}]'='True'

  • '' = 'True' = False
  • Failed: Skipping child actions.
  • In this particular instance the file is a jpg, and if I try with another file type such as a word document, I see the same result.  Have I made a mistake or is anyone else seeing this?

    Many thanks


    New Post
    7/22/2018 11:09 AM

    That fails because the formatter is expecting the incoming parameter to be a path to a file to verify it, rather than the physical file itself.

    Instead, you want to use the Input File Values:

    [frmFile.Path,Form] – returns the full directory name of the file that is received through the form, from the source machine.
    [frmFile.Name,Form] – returns the full file name, including the extension of the file.
    [frmFile.NameOnly,Form] – returns the name, without the extension for the file.
    [frmFile.Extension,Form] – returns the extensions of the file.
    [frmFile.Type,Form] – returns the MIME type (discussed in the appendix)
    [frmFile.Length,Form] – returns the physical byte length of the incoming file.
    [frmFile.Height,Form] – Returns the vertical height of the file if the file is an Image
    [frmFile.Width,Form] – Returns the horizontal width of the file if the file is an Image

    In your case you can check to see if the Type starts with Image, or if the Width or Height is not equal to Undefined.

    If '[frmFile.Width]'!='Undefined'

    Kevin M Schreiner
    Open Web Studio
    PayPal - The safer, easier way to pay online!
    New Post
    11/29/2018 6:54 AM

    Kevin, 9.2.2 still has a bug on the OWS administration page. The paging control beneath the list of OWS modules is missing. I found the culprit was with the changes you made to function FetchStart in OWS.js. I restored that function to its previous state and the paging control is visible and works once again.

    New Post
    12/30/2018 8:58 AM
    I don't know if this is a new problem or just me.

    I seem to remember managing this years ago but can't be sure.


    I don't have the ability to try it on an earlier version at the moment.


    I want to access a different database in a SUBUERY so I've added connection="[MyAltDB, configuration]" to it.
    In web.config I've added the add key MyAltDB in appSettings with the connection string and all seems fine but it doesn't work.

    The server in the connection string is referenced by (IPAddress, Port) but when I look in the Event Log it shows the connection string is truncated at the comma before the Port number! I tried it as a colon which doesn't work but the whole string does show up in the Event Log correctly. I have to add the port as it is user defined.

    Is it me, OWS or a bug in 2.3.2 Alpha?
    HomeHomeCoreCoreGeneralGeneralOpenWebStudio 02.03.02 (ALPHA) is available! OpenWebStudio 02.03.02 (ALPHA) is available!


    New York, NY • Baltimore, MD • Vienna, VA • St. Louis, MO • Seattle, WA •

    Bookmark & Share Bookmark and Share